1991 Chevy S 10 Pick Up Won’t Start – No Spark or Fuel

Reader Question
My son has a 91 s-10 with a 2.5 engine. We have changed the ecm and injector, dist. cap and rotor and wires and plugs. We are not getting any fire to the plugs and the new injector is not spitting fuel. It is getting fuel to the injector. Is there a hidden fuse or what I checked the ecm fuse under the dash and the are good. What else could it be.

Yours Truely,
Mark

Hi Mark,

I would start with the basics. If you don’t have spark, test/replace the ignition coil. I can’t recall a separate fuse in the fuse block for ECM on a 91, but I would definitely check all of them just for the heck of it. Just looking at the fuel injector as you crank over the engine is not an accurate way to test it or to even assume that you are getting proper fuel supply and pressure.

You have to check fuel pressure with a fuel pressure gauge using the pressure valve located on the fuel rail. The computer is not going to just keep squirting fuel as you crank the engine…that would just flood it.

No Spark?

If you don’t have spark…fix that problem first then see what happens.

1. Does ignition coil have power from battery

2. Does coil produce a spark

3. Does that spark make it to the distributor

4. Is there spark coming out of the distributor

No fuel? –

Is electric in tank fuel pump working when you turn key to on position? Can you hear it prime up for 3 seconds?

If no noise is heard from tank on key on position, have someone crawl under truck and hit the bottom of the tank with a runner hammer or with their fist AS you crank over engine. This will jump start a weak fuel pump. Chevy trucks are notorious for weak fuel pumps.

If you feel the ignition coil is working ok, I would test/replace the ignition module and pick up coil located inside the distributor as my best guess for your problem.

Blessings,
Austin C. Davis

Posted in: Uncategorized

1 Comment on "1991 Chevy S 10 Pick Up Won’t Start – No Spark or Fuel"

Trackback | Comments RSS Feed

  1. rick says:

    Hey mark I have the same problem ..what did you find out?

Got Something to Say?